sv572 re born

What people are working on at the moment
Post Reply
User avatar
ed
retired
Posts: 4167
Joined: Thu Jun 21, 2007 4:01 pm
Location: yorkshire
Contact:

sv572 re born

Post by ed » Thu May 30, 2019 7:35 am

Following the temporary re-birth of the sv572 for Owston I had to do a bit of revision regarding the sv572 and valves in general. I brushed off the cobwebs, read my old notes and re-biased it, and it sounds great(to me).

I did some measurements with the scope and found that between 0v and 1.2v RMS input it has a consistent gain of 3.8 at 1k but as the input increases above 1.2v there is a very slight flattening of the waveform at the bottom and the gain drops to 3.75. I guess the clip point with this set-up is at just under 3 watts then, with an output of 4.55v into 8 ohms.

With the bias at 90v and anode at 500v it idles at 50ma. I drew out the expected loadline for 5k and this figure(50ma) is way below expected. I'm not sure why this is at the mo but it'll be exciting to find out. I'm sure I was aware of this way back in the day but there wasn't any mention in the build notes.

So, not content to just listen to it, I decided to model the circuit in spice, something I'd never done with this amp. Using Duncan's model for the sv572 I got some very curious results. The model shows a gain of about 1. The front end(aikido) models perfectly for voltage gain but the back end seems very strange. I'm very curious about this bit and will pursue it.

All in all a pleasant diversion form the normal time-wasting endeavours. I'm hoping I can persuade Steve to let me hook up to his baffles to hear the best from this.
sv572 cct.jpg
There's nowhere you can be that isn't where you're meant to be

User avatar
IslandPink
Oooo, Roberts Radio's sound nice
Posts: 7687
Joined: Tue May 29, 2007 7:01 pm
Location: Denbigh, N.Wales

Re: sv572 re born

Post by IslandPink » Thu May 30, 2019 8:12 am

Presumably at -90 bias there's no grid current ?
"The bass is the king of the instruments - it has no known natural predator" (Wobble)

User avatar
ed
retired
Posts: 4167
Joined: Thu Jun 21, 2007 4:01 pm
Location: yorkshire
Contact:

Re: sv572 re born

Post by ed » Thu May 30, 2019 8:27 am

No...no A2!

my bad I should have mentioned. I'm actually using sv811-3a in this version and that doesn't show any A2 on the datasheet. SV572 shows A2 curves for positive grid.

there may be stray stuff but I'm not sure:

a) if it's there
b)how to measure it if it is there
c) what effect the fixed bias cap would have on any grid current if there actually were any.

today I have to go and fix(hopefully) a persistent warning light in the car. OBD2 codes indicate a ECT sensor fault so the garage has changed both sensors and the thermostat and the light still keeps coming on. So today I'm taking matters into my own hands and getting dirty. So I won't be able to reply further today.
There's nowhere you can be that isn't where you're meant to be

User avatar
Mike H
Amstrad Tower of Power
Posts: 18691
Joined: Sat Oct 04, 2008 5:38 pm
Location: The Fens
Contact:

Re: sv572 re born

Post by Mike H » Thu May 30, 2019 8:18 pm

If it's not behaving the same as the real amp, I venture to suggest the sv572 model may not be realistic enough.
 
"Entrenched convictions cannot be changed by facts." – Dick Francis

User avatar
ed
retired
Posts: 4167
Joined: Thu Jun 21, 2007 4:01 pm
Location: yorkshire
Contact:

Re: sv572 re born

Post by ed » Thu May 30, 2019 8:31 pm

or I've screwed up the model for the 5k se transformer....
I couldn't find any inductance figures for the James so I used standard Hammond figures for a 1628...I hope I've got that right. I've never modelled a transformer before.
There's nowhere you can be that isn't where you're meant to be

User avatar
Paul Barker
Oooo, Roberts Radio's sound nice
Posts: 7196
Joined: Mon May 21, 2007 9:42 pm

Re: sv572 re born

Post by Paul Barker » Sat Jun 01, 2019 1:56 pm

I’d estimate the James uses better core material, meaning you’re estimate would be bettered.
"Two things are infinite, the universe and human stupidity, and I am not yet completely sure about the universe." – Albert Einstein

User avatar
ed
retired
Posts: 4167
Joined: Thu Jun 21, 2007 4:01 pm
Location: yorkshire
Contact:

Re: sv572 re born

Post by ed » Mon Jun 03, 2019 11:03 am

sorted!

I screwed up the transformer model...I had the leakage figure wrong: 0.95 should have been 0.999

doh!

wish I'd thought of spice for valves back in the day, it would have prevented lots of wasted effort...it also kicks you in the arras when you start to assume things.
There's nowhere you can be that isn't where you're meant to be

Post Reply